ArchiveUploader 0.3.4 をリリース

MT > ArchiveUploader
| | コメント(2) | トラックバック(0)

バージョン 0.3.4 をリリースしました。

修正点は以下の通りです。

  • 0.3.3 で発生していた、「ファイルが正しく展開されない」という不具合が修正されました。

修正点は以上になります。

動作しないバージョンが最新版となったまま時間が経ってしまい申し訳ありませんでした。

ダウンロードページ

トラックバック(0)

このブログ記事を参照しているブログ一覧: ArchiveUploader 0.3.4 をリリース

このブログ記事に対するトラックバックURL: http://tec.toi-planning.net/mtos/mt-tb.cgi/899

コメント(2)

FULL_bayashi :

新バージョンリリース、ありがとうございます。
さっそく使用させていただきましたが、うまく利用できませんでした、MT4.27です。
アップロードしようとすると「CMSが利用できません」となります。

あと、これはご要望なのですが、同一ファイル名は置き換えられますが、これを回避するように出来ないでしょうか。
例えば「同一ファイル名が存在しています、上書きしてもよろしいですか?はい> いいえ>」などです。

勝手な要望失礼いたしました。

yyps :

早速ご対応くださりまして、誠にありがとうございます。
0.3.4を試させていただきましたが、0.3.3と症状が変わらず、zipが展開されませんでした。

当方の環境の方にもクセがあるのではないかと思っておりますが、何か解決策があれば教えていただければ幸いです。
具体的な症状は下記の通りです。

[症状]

・アップロードボタンを押すと、mt.cgiより下記のエラーメッセージが出る。
・アイテムには登録されているが、ファイルが展開されない。
・tempディレクトリにはzipが保存されている。

######################################################################
エラーが発生しました: Can't locate MT/Theme.pm in @INC (@INC contains:
[mtのパス]\plugins\WXRImporter\lib

|

(Perl の インクルードパス)

|

[mtのパス]\extlib
[mtのパス]\extlib
lib ← [mtのパス]が表記されていない
[その他パス]/lib
[その他パス]/lib
.)
######################################################################

MT/Theme.pmは "[mtのパス]\lib" の中に格納されていますが、[mtのパス]がつかない状態になっていました。

[環境]
・Movable Type バージョン 5.01
・オペレーティングシステム MSWin32
・Perl のバージョン 5.8.7
・ウェブサーバー Microsoft-IIS/6.0
・Archive::Zip バージョン 1.14

コメントする