CKEditor for Movable Type 1.06-pre4 をリリース

MT > CKEditorForMT
| | コメント(10) | トラックバック(0)

バージョン 1.06-pre4 をリリースしました。

バージョン 1.06-pre3 で不十分であった 3.3 への対応を改善しました。

pre3 に引き続きテストができていない状況なのですが、不具合などありましたら、コメントをいただけると大変ありがたいです。

ダウンロードページ

トラックバック(0)

このブログ記事を参照しているブログ一覧: CKEditor for Movable Type 1.06-pre4 をリリース

このブログ記事に対するトラックバックURL: http://tec.toi-planning.net/mtos/mt-tb.cgi/902

コメント(10)

cotenthe :

早速バージョンアップしてテストさせいただきました
・MT5.02の環境下でpre3の不具合修正を確認しました
・CKEditor内の右クリックメニューのカーソル表示修正を確認しました

・IE6/7にてテンプレート機能を利用するとテンプレート選択直後に下記エラーが出るのを確認しました(しかしそのままでも操作上支障はありません)
ページでエラーが発生しました
'pageYOffset' は Null またはオブジェクトではありません。

また何かありましたらご報告致します

cotenthe :

度々すみません、これは不具合ではありませんが
標準でスペルチェック機能がONになっていますが、OFFのが良いと思います
ONだと右クリックメニュー時におかしな表示が出ます
宜しくお願い致します

cotenthe :

スペルチェック機能の件はCKEditor側でデフォルトONになってるようですね、申し訳ございません

システムのPlugin設定→その他の設定で
// SCAYT OFF
config.scayt_autoStartup = false;
で対処しました

一応ご報告します

Taku AMANO :

cotentheさん、ありがとうございます。

頂いたお話を参考に、こちらでもデフォルトの設定について検討してみます。
またよろしくお願いいたします。

青 :

導入してみたところ、プラグインを選択したところ
Can't use string ("MSA£A・o") as a HASH ref while "strict refs" in use
とのようなエラーが表示されてしまいました。
前のバージョンは大丈夫そうなのですが。

よろしくお願い致します。

Taku AMANO :

cotentheさん、コメントありがとうございあす。

テンプレートのエラーについて確認したのですが、どうもオリジナルの CKEditor からの問題で、スペルチェックが有効になっている状態でテンプレート機能を使うと発生してしまうようですね。

書いていただいた通り差し当たり大きな問題は起きないようなので、まずはそのままリリースしてしまいました。

1.06の方も、よろしければお試しいただければと思います。

Taku AMANO :

青さん、コメントありがとうございます。

1.06 の近辺では CKEditor のJavaScirpt の辺りの修正だけなので、頂いたようなエラーが発生しそうな状況がいまのところ分かっていません。

「プラグインを選択したところ」の辺りは、具体的にはどのような操作を行なったタイミングでしょうか。差し支えがなければ教えて頂ければと思います。

よろしくお願いいたします。

青 :

ご回答ありがとうございます。
まずは、新規にファイルをアップしました。その時点でプラグインを選択したところ上記のような形になりました。
また、ブログやWebページをみたときにJavaScirptエラーが検出されました。
---------------------------------------
CKEITORは宣言されていません。
MT_APP_EDITOR__CKEDITOR.JS ライン60
コード:0 文字:4
と記事のほうに表示されて入力ウィンドウが表示されなくなっていました。
---------------------------------------
pluginsからCKEditorを削除すると通常の入力画面が表示されます。

よろしくお願い致します。

青 :

お世話になります。

別の症状で文字入力を続けて、何回かEnterキーで確定していくわけですが、文字に赤い波線がついて更に入力を続けると今まで入れていた文字が消えてしまいました。

あわせてご報告ということで。

よろしくお願い致します。

kate :

CKEditor for Movable Type 1.06-pre4を使用し、挿入した画像にrel="lightbox"をつけるためフォーマットなしに変更し右側にあるスライドバーを下にスライドすると正常に動作しません。(下向きボタンが表示されない、バーが途中で止まる)
プラグインを停止し、デフォルトの状態では正常に動作しますのでプラグインの問題だと思いますが、直し方が分かりません。
使用しているブラウザーはファイヤーフォックスです。

コメントする