CKEditor for Movable Type 1.073 を公開

MT > CKEditorForMT
| | コメント(11) | トラックバック(0)

バージョン 1.073 を公開しました。

MT5.1に対応したバージョンです。(MT 5.1 より前のバージョンでも引き続き利用できます)

1.061 からの主な変更点は以下の通りです。

  • 同梱されている CKEditor のバージョンが 3.3.1 から 3.5.2 に更新されました。
  • MT5.1 に対応しました。 (MT 5.1 より前のバージョンでも引き続き利用できます)
  • 細かい不具合が修正されました。

1.07-beta1〜1.072までは特にフォーマットの切り替え部分で不安定な状態が続きましたが、頂いたコメントを参考にして修正することができました。皆様ありがとうございました。

ダウンロードページ

トラックバック(0)

このブログ記事を参照しているブログ一覧: CKEditor for Movable Type 1.073 を公開

このブログ記事に対するトラックバックURL: http://tec.toi-planning.net/mtos/mt-tb.cgi/966

コメント(11)

マホミ :

ご多忙中大変恐れ入ります
movable type を使用していますが、大変困っていることがあります

CKEditor1.073が MT5.12で作動しません
(編集ページにボタンが出てきません)
プラグインなど調べたのですがきちんとインストールされているようです

コミュニティでも聞いてみたのですが、うまくいきませんでした
http://communities.movabletype.jp/2011/07/ckeditor-1073.html

何かご存知のことがありましたら教えていただけると大変助かります
どうぞよろしくお願いいたします

melodicant :

マホミさんのトラブルの件ですが、当方環境でも同じような問題が発生しました。

さくらサーバ(スタンダード)での1.073の動作は全く問題ないのですが、lolipopサーバに同様環境でインストールしたところ、マホミさんのトラブルのような「編集ページにボタンが出てこない」に類する問題が発生しています(同じ症状かどうかはわかりません)。なお、ブラウザはFF501/Chrome13 Macで確認しています。

ボタンが出てこないというよりは、ボタンの背景画像が読み込めていない状態で、要素自体は機能しています(クリックすれば動作)。ただし、2〜3個の画像のみ(当方環境では絵文字とアイテム挿入系のみ)表示されています。背景画像が見えないので、何のボタンかわからず、「編集ページにボタンが出てこない」に相当する状態です。

Firebugで確認すると、表示されている画像はフルURIで背景画像が指定できていますが、その他の表示されていない背景画像は相対パスになっているようです。

skinsファイルが読めていないのなら全てのボタンが表示されないはずですが、画像が出るものもあって、なおかつ画像パス指定の状態が異なるようなので、一度ご確認いただければ幸いです。

melodicant :

上記の件、ほぼ解決しました。単なるFTPの問題のようでした。

きちんと転送を何度もしたつもりでしたが、うまく設置されていなかったようです。違う時期にインストールしたQuickRebuildプラグインも、アイコンが出ない問題が出ていましたが、同じように再度FTPして解決しました。lolipopサーバはFTPで問題があるんでしょうか...さくらサーバでは全く起きなかったトラブルです。

いずれにせよ、何らかの作業をなさっていたとすれば無駄なことになってしまい、お詫びいたします。

ぽんこつ :

ぽんこつです。

CKEditor1.073が MT5.12でワードから文書を貼り付けすると、スタイル(文字の色、大きさ、表の色など)が反映されません。
対応方法を教えてください。宜しくお願いします。

よしちょう :

MT5.12にてインストールさせていただきました。
サーバはWADAXです。
すると、本文の入力欄が消えてしまい、何も打てなくなってしまいました。

koki :

素晴らしいプラグインをありがとうございます!
すごい便利ですねー。

いろいろと調べてみたのですがどうしてもわからないことがあるのですが、

という風にMTタグを解釈するようにしたあとに
ウェブページでMTタグを入力しても

<$MTBlogURL$>

こんな感じで変更されてしまってMTタグとして
解釈してもらえません。

いい方法があればご教授頂けませんでしょうか。
何卒宜しくお願いいたします。

rinopo :

はじめまして。

とても有用なプラグインを公開していただき、感謝しております。

MT 5.02 + CKEditor 1.073 を使用させていただいています。
当方の環境で、以下のような現象が起きることに気づいたため、書き込ませていただいております。


・ブログ記事編集画面の「本文」やその他カスタムフィールドにCKEditorを使用しています。

・CKEditorを使用しているフィールドに文字を入力(もしくはすでに入力されているエントリーを開く)。

・編集画面右上の「表示オプション」プルダウンを開き、入力項目の表示/非表示や順序を変更。

その瞬間に、CKEditorを使用しているフィールド内に入力済みの内容がクリアされてしまいます。
また、その後、CKEditorを使用しているフィールドへの入力(フォーカス)自体できなくなってしまいます。


Firefox / Safari / Chrome(それぞれ最新版)でこの現象を確認しました。

CKEditorとデフォルトで入っているプラグイン以外のMTプラグインは、すべて無効にした状態で確認しています。

IE6〜7 ではこの現象は起きませんでした。

また、別のプロジェクトで使用している MT 5.12 + CKEditor 1.073 の組み合わせでも、この現象は起きていません。

(Firebugで様子を見ると、入力内容が消える瞬間に、CKEditorのiframe内のclassやidも消去されてしまうようです。)


これは再現性がある現象でしょうか。
解決策はありそうでしょうか。

長々とすみません。
ご助力いただけますと大変ありがたいです。

rinopo :

先日コメントした、CKEditorのフィールドの入力内容が消えてしまう件です。

> IE6〜7 ではこの現象は起きませんでした。

と書きましたが、×「IE6〜7」→ ○「IE6〜8」の書き間違いでした。

また、IE9 では、やはりこの現象が起きるようです。

Tsujita :

MTA 5.13 で CKEditor1.073を利用している環境においてCKEditorが不思議な動作をしますので、質問させてください。

■ 現象
ブログ記事の入力中に、リッチテキストエディタを使って記事を入力します。
その際、マウスを使って文中の任意の文字列を範囲指定し、別の場所にドラッグしたとたんにフォントサイズが変わります。
この現象は Ctrl+X, Ctrl+V で文字のカット&ペーストを行っても同じことが起こります。
フォント指定は
ああああああああ!
などのように、フォントサイズの直接指定で記述され、%指定ではありません。
OSは XP SP3、ブラウザはIE8で、ブラウザモードがIE8、ドキュメントモードもIE8標準です。

ただし、テスト環境などでこの現象を再現することはできませんでした。問題の切り分け方法も含め、解決策をご教示いただければ幸いです。

レイン :

お世話になっております。
5.2からはエディタが変わったのでCKEditorが入っていても動かなくなっているみたいです。
フォーマット選択からも切り替えられないようです。
Tableとか入れられないのが不便なので戻したいが戻せないという悪循環パターンのようです。

first :

はじめまして。いつもプラグインを利用させていただいております。
現MT5.2.2でCKEditor1.073利用しています。

リンク挿入ボタンをクリックし、リンクを設定しOKを押した後、記事の編集作業が出来なくなってしまいます。

ハイバーリンク挿入のWindowは消えるのですが、Lightbox的に表示される背景の半透明の白部分が全体に残っている感じです。

何か対処法がございましたら、ご教授いただけますと助かります。
他のボタンは正常に動作しております。

以上、どうぞよろしくお願いいたします。

コメントする